股票数据网 股票公式
首页 我的自选股 qg111钱柜官网 数据中心 qg111钱柜股票快讯 股票入门 股票进阶 理财知识 股票论坛 股票大全
帮助中心 关于我们
返回上一页

通达信主图指标公式 通达信资金叠加成交量主图指标公式

编辑 : 王远   发布时间: 2017.08.06 23:37:07   消息来源: 股票入门 阅读数: 302 收藏数: 0 + 收藏 (0)
  通达信主图指标公式 通达信资金叠加成交量主图指标公式:   套盘:=(1-WINNER(C))*100,COLORGREEN,NODRAW;...

  通达信主图指标公式 通达信资金叠加成交量主图指标公式:

  套盘:=(1-WINNER(C))*100,COLORGREEN,NODRAW;

  TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));

  MTIME:=MOD(FROMOPEN,TOTAL);

  CTIME:=IF(MTIME《0.5,TOTAL,MTIME);

  VVOL:=IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;

  虚拟换:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME/CAPITAL*100,DRAWNULL),COLORGREEN,NODRAW;

  换手:VOL/CAPITAL*100,POINTDOT,NODRAW,COLORMAGENTA;

  STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),VVOL,0,-1,-1),COLOR00C0C0;

  超B:=L2_AMO(0,2)/10000.0;

  大B:=L2_AMO(1,2)/10000.0;

  中B:=L2_AMO(2,2)/10000.0;

  小B:=L2_AMO(3,2)/10000.0;

  超S:=L2_AMO(0,3)/10000.0;

  大S:=L2_AMO(1,3)/10000.0;

  中S:=L2_AMO(2,3)/10000.0;

  小S:=L2_AMO(3,3)/10000.0;

  净流入:(超B+大B+中B+小B)-(超S+大S+中S+小S),NODRAW;

  N:=30;

  ZJD:=HHV(净流入,N);

  ZJX:=LLV(净流入,N);

  CJ:=HHV(V,N);

  BEIS:=CJ/(ZJD-ZJX);

  值:=CONST(CJ+ABS(ZJX)*BEIS);

  STICKLINE(净流入》0 ,值,值+净流入*BEIS,2,0),COLOR0000AA;

  STICKLINE(净流入《=0 ,值,值+净流入*BEIS,2,0),COLOR00AA00;

  DRAWTEXT(ISLASTBAR=1 AND 净流入《=0,值*1.12,‘ 净流入’),COLORGREEN;

  DRAWTEXT(ISLASTBAR=1 AND 净流入》0,值*0.88,‘ 净流入’),COLORRED;

  VOLUME:VOLVOLSTICK;

  V1:=MA(VOLUME,5);

  V2:=MA(VOLUME,10);

  V3:=MA(VOLUME,30);

  {空中加油}

  STICKLINE(C《O AND C》REF(C,1),0,V,2,0),COLORMAGENTA;

  量倍:V/REF(V,1),NODRAW,COLOR0000DD;

  STICKLINE(IF(V》REF(HHV(V,239),1),0.99,1)《1,V,0,-1,1),COLORDD00DD;

  STICKLINE(IF(V》REF(HHV(V,239),1),0.99,1)《1 AND O》C,V,0,-1,0),COLORDD00DD;

  STICKLINE(IF(V《REF(LLV(V,119),1),0.99,1)《1,V,0,-1,0),COLOR00DD00;

  STICKLINE(IF(V《REF(LLV(V,239),1),0.99,1)《1,V,0,-1,0),COLORDD0000;

  STICKLINE(V/REF(V,1)》2 ,0,V/2,2,0),COLORYELLOW;

  DRAWICON(LAST(V》REF(V,1),2,0),V/3,1);

  TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);

  超大单:=(超B)-(超S);

  大单:=(大B)-(大S);

  中单:=(中B)-(中S);

  小单:=(小B)-(小S);

  DAZHI:=CONST(MAX(ABS(净流入),MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单)))))),NODRAW;

  近3净入:=SUM(净流入,3);

  近3超:=SUM(超大单,3);

  近3大:=SUM(大单,3);

  近3中:=SUM(中单,3),;

  近3小:=SUM(小单,3);

  近5净入:=SUM(净流入,5);

  近5超:=SUM(超大单,5);

  近5大:=SUM(大单,5);

  近5中:=SUM(中单,5);

  近5小:=SUM(小单,5);

  近10净入:=SUM(净流入,10);

  近10超:=SUM(超大单,10);

  近10大:=SUM(大单,10);

  近10中:=SUM(中单,10),;

  近10小:=SUM(小单,10);

  流入:=ABS(超B+大B+中B+小B)*1000/VOL;

  流出:=ABS(超S+大S+中S+小S)*1000/VOL;

  近3流入:=ABS(SUM(超B,3)+SUM(大B,3)+SUM(中B,3)+SUM(小B,3))*1000/VOL;

  近3流出:=ABS(SUM(超S,3)+SUM(大S,3)+SUM(中S,3)+SUM(小S,3))*1000/VOL;

  近5流入:=ABS(SUM(超B,5)+SUM(大B,5)+SUM(中B,5)+SUM(小B,5))*1000/VOL;

  近5流出:=ABS(SUM(超S,5)+SUM(大S,5)+SUM(中S,5)+SUM(小S,5))*1000/VOL;

  近10流入:=ABS(SUM(超B,10)+SUM(大B,10)+SUM(中B,10)+SUM(小B,10))*1000/VOL;

  近10流出:=ABS(SUM(超S,10)+SUM(大S,10)+SUM(中S,10)+SUM(小S,10))*1000/VOL;

  { 当日 }

  DRAWRECTREL(0,0,240,999.2,IF(120,RGB(10,0,0),0));

  {DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0,0.001,0,‘单位(万元)’),COLORDDDDDD;}

  DRAWRECTREL(0,ABS(CONST(480-(ABS(净流入)*300/DAZHI))),44,480,IF(CONST(净流入)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(48,ABS(CONST(480-(ABS(超大单)*300/DAZHI))),94,480,IF(CONST(超大单)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(98,ABS(CONST(480-(ABS(大单)*300/DAZHI))),142,480,IF(CONST(大单)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(146,ABS(CONST(480-(ABS(中单)*300/DAZHI))),190,480,IF(CONST(中单)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(194,ABS(CONST(480-(ABS(小单)*300/DAZHI))),238,480,IF(CONST(小单)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0,0.001,0,‘当日’),COLORFFFFFF;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.005,0.49,0,‘净流’),COLORRED;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.055,0.49,0,‘超大’),COLOR00FFFF;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.100,0.49,0,‘大单’),COLOR00FFFF;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.49,0,‘中单’),COLOR00FFFF;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.197,0.49,0,‘小单’),COLOR00FFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.0,0.40,0,CEILING(净流入)),COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.051,0.40,0,CEILING(超大单)),COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.097,0.40,0,CEILING(大单)),COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.151,0.40,0,CEILING(中单)),COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.200,0.40,0,CEILING(小单)),COLORFFFFFF;

  {3日 }

  DRAWRECTREL(240,0,445,999.2,IF(120,RGB(10,0,0),0));

  DRAWRECTREL(0,CONST(940-(ABS(近3净入)*10/DAZHI)),42,999,IF(CONST(近3净入)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(47,CONST(940-(ABS(近3超)*10/DAZHI)),94,999,IF(CONST(近3超)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(98,CONST(940-(ABS(近3大)*10/DAZHI)),142,999,IF(CONST(近3大)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(146,CONST(940-(ABS(近3中)*10/DAZHI)),190,999,IF(CONST(近3中)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(194,CONST(940-(ABS(近3小)*10/DAZHI)),238,999,IF(CONST(近3小)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.001,0.89,0,CEILING(近3净入))COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.058,0.89,0,CEILING(近3超))COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.106,0.89,0,CEILING(近3大))COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.155,0.89,0,CEILING(近3中))COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.200,0.89,0,CEILING(近3小))COLORFFFFFF;

  { 5}

  DRAWRECTREL(240,ABS(CONST(480-(ABS(近5超)*50/DAZHI))),285,480,IF(CONST(近5超)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(290,ABS(CONST(480-(ABS(近5大)*50/DAZHI))),335,480,IF(CONST(近5大)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(341,ABS(CONST(480-(ABS(近5中)*50/DAZHI))),386,480,IF(CONST(近5中)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(395,ABS(CONST(480-(ABS(近5小)*50/DAZHI))),440,480,IF(CONST(近5小)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.245,0.49,0,‘绝对超’),COLORFF8000;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.294,0.49,0,‘绝对大’),COLORFF8000;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.343,0.49,0,‘绝对中’),COLORFF8000;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.394,0.49,0,‘绝对小’),COLORFF8000;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.244,0.40,0,CEILING(近5超)),COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.295,0.40,0,CEILING(近5大)),COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.350,0.40,0,CEILING(近5中)),COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.395,0.40,0,CEILING(近5小)),COLORFFFFFF;

  { 10 }

  DRAWRECTREL(240,ABS(CONST(970-(ABS(近10超)*10/DAZHI))),289,999,IF(CONST(近10超)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(293,ABS(CONST(970-(ABS(近10大)*10/DAZHI))),337,999,IF(CONST(近10大)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(341,ABS(CONST(970-(ABS(近10中)*10/DAZHI))),386,999,IF(CONST(近10中)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWRECTREL(395,ABS(CONST(970-(ABS(近10小)*10/DAZHI))),440,999,IF(CONST(近10小)》0,RGB(100,0,0),RGB(0,50,0)));

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.244,0.90,0,CEILING(近10超)),COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.295,0.90,0,CEILING(近10大)),COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.350,0.90,0,CEILING(近10中)),COLORFFFFFF;

  DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.395,0.90,0,CEILING(近10小)),COLORFFFFFF;

  大宗进:=(超B)+(大B),NODRAW;

  大宗出:=(超S)+(大S),NODRAW;

  非大宗进:=(中B)+(小B),NODRAW;

  非大宗出:=(中S)+(小S),NODRAW;

  大宗进限制:=IF((超B+大B)=0,0,大宗进);

  大宗出限制:=IF((超S+大S)=0,0,大宗出);

  非大宗进限制:=IF(中B+小B=0,0,非大宗进);

  非大宗出限制:=IF(中S+小S=0,0,非大宗出);

  主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;

  散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;

  大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;

  大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);

  大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;

  大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);

  总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

  总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

  成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;

  机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;

  大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;

  大单强度限制:=IF(大单强度=0,-100,大单强度);

  大单强度比:=IF(大单强度》=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;

  超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;

  超单强度限制:=IF(超单强度=0,-100,超单强度);

  超单强度比:=IF(超单强度》0,(超单强度限制+100)/2,IF(超单强度《0,100-ABS((超单强度限制-100)/2),0)),NODRAW;

  资金流向买:=大宗进限制+非大宗进限制;

  资金流向卖:=大宗出限制+非大宗出限制;

  流入比:=净流入*1000000/AMOUNT,NODRAW;

  大宗净流入:=(超B+大B)-(超S+大S),NODRAW;

  大宗流入比:=大宗净流入*1000000/AMOUNT,NODRAW;

  DRAWRECTREL(00,0,240,95,RGB(0,100,0));

  DRAWRECTREL(00,0,120,95,RGB(0,100,0));

  DRAWRECTREL(00,0,20+CONST(总流入比*160/100),95,RGB(100,0,0));

  DRAWTEXT_FIX(1,0.00,0.01,0,STRCAT(STRCAT(‘今日流向 ’,CON2STR(资金流向买,0)),‘ ’)),COLORYELLOW;

  DRAWTEXT_FIX(1,0.17,0.01,0,STRCAT(STRCAT(‘ ’,CON2STR(资金流向卖,0)),‘ ’)),COLORYELLOW;

  DRAWRECTREL(00,570,285,661,RGB(0,100,0));

  DRAWRECTREL(00,570,285,661,RGB(0,100,0));

  DRAWRECTREL(00,570,150+CONST(大宗流入比*160/100),661,RGB(100,0,0));

  DRAWTEXT_FIX(1,0.1,0.58,1,STRCAT(STRCAT(‘机构介入度 ’,CON2STR(大宗流入比,0)),‘ ’)),COLORYELLOW;

  DRAWRECTREL(240,570,443,661,RGB(0,100,0));

  DRAWRECTREL(240,570,360,661,RGB(0,100,0));

  DRAWRECTREL(240,570,270+CONST(流入比*160/100),661,RGB(100,0,0));

  DRAWTEXT_FIX(1,0.35,0.58,1,STRCAT(STRCAT(‘资金介入度 ’,CON2STR(流入比,0)),‘ ’)),COLORYELLOW;

  主买A:=ACTINVOL,COLORRED,NODRAW;

  主卖A:=ACTOUTVOL,COLORGREEN,NODRAW;

  主买:主买A*100/(主买A+主卖A),NODRAW,COLORRED;

  主卖:主卖A*100/(主买A+主卖A),NODRAW,COLORGREEN;

  DRAWRECTREL(240,0,443,95,RGB(0,100,0));

  DRAWRECTREL(240,0,443,95,RGB(0,100,0));

  DRAWRECTREL(240,0,280+CONST(主买*160/100),95,RGB(100,0,0));

  DRAWTEXT_FIX(1,0.25,0.01,0,STRCAT(STRCAT(‘主动买卖比 ’,CON2STR(主买,2)),‘ %’)),COLORYELLOW;

发布评论

最新评论

  • 暂无评论
推荐知识
相关热点文章