股票数据网 股票公式
首页 我的自选股 qg111钱柜官网 数据中心 qg111钱柜股票快讯 股票入门 股票进阶 理财知识 股票论坛 股票大全
帮助中心 关于我们
返回上一页

股票的公式有哪些?飞狐控盘主图公式源码

编辑 : 王远   发布时间: 2017.08.06 23:37:07   消息来源: 股票入门 阅读数: 313 收藏数: 0 + 收藏 (0)
股票的公式有哪些?飞狐控盘主图公式源码 附:飞狐牛气冲天副图指标公式  南方财富网小编为您提供 【飞狐控盘主图公式源码】 //筹...

股票的公式有哪些?飞狐控盘主图公式源码 附:飞狐牛气冲天副图指标公式  南方财富网小编为您提供

【飞狐控盘主图公式源码】

//筹码分布WRAP: break-word; WHITE-SPACE: normal; TEXT-TRANSFORM: none; WORD-SPACING: 0px; COLOR: rgb(51,51,51); PADDING-BOTTOM: 0px; PADDING-TOP: 0px; FONT: 14px/24px 宋体, arial, sans-serif, 'DejaVu Sans', 'Lucida Grande', Tahoma, 'Hiragino Sans GB', STHeiti, SimSun, sans-serif; PADDING-LEFT: 0px; MARGIN: 0px; WIDOWS: 1; LETTER-SPACING: normal; PADDING-RIGHT: 0px; TEXT-INDENT: 0px; -webkit-text-stroke-width: 0px">input:n(14,1,100);explain(1,'所属板块\n'+BLKNAME+'\n'),COLOR336600;cost(30),linedot,linethick1,colorff9933;cost(70),linedot,linethick1,colorff9933;cost(90),linedot,linethick1,colorff9933;cost(10),linedot,linethick1,colorff9933;cmjz:=(cost(95)-cost(5))/(cost(95)+cost(5))*100;筹码集中度%:100-cmjz,colorblue,linethick;获利盘%:winner(c)*100,colorblue,linethick;mcst:DMA(AMOUNT/(100*VOL),VOL/CAPITAL),color6666cc,circledot;//mmcst:ma(mcst,n),color6666cc,circledot;1.2*mcst,linedash,color6666cc;1.3*mcst,linedash,color6666cc;//财务指标cwzbqs:=F10FIND('财务指标-盈利能力',8000);cwzbq00:=F10FIND('指标名称 ',cwzbqs);cwzbq0:=F10FIND('销售毛利率(%)',cwzbqs+10);cwzbq1:=F10FIND('主营业务利润率(%)',cwzbq0+70);cwzbq2:=F10FIND('加权净资产收益率',cwzbq1+70);cwzbq3:=F10FIND('主营业务收入增长率',cwzbq2+70);cwzbq4:=F10FIND('净利润增长率',cwzbq3+70);cwzbt00:=f10text(cwzbq00,0);cwzbt0:=f10text(cwzbq0,0);cwzbt1:=F10TEXT(cwzbq1,0);cwzbt2:=F10TEXT(cwzbq2,0);cwzbt3:=F10TEXT(cwzbq3,0);cwzbt4:=F10TEXT(cwzbq4,0);DRAWTEXTEX(C,1,0,870,' '+cwzbt00+'\n'+cwzbt0+'\n'+cwzbt1+'\n'+cwzbt2+'\n'+cwzbt3+'\n'+cwzbt4),colorgray;//评级tzpjqs:=F10FIND('1.投资评级',90000);tzpjq1:=F10FIND('统计时段',tzpjqs+40);tzpjq2:=F10FIND('15天以内',tzpjq1+40);tzpjq3:=F10FIND('1个月以内',tzpjq2+40);tzpjq4:=F10FIND('2个月以内',tzpjq3+40);tzpjq5:=F10FIND('3个月以内',tzpjq4+40);tzpjq6:=F10FIND('6个月以内',tzpjq5+40);tzpjt1:=' '+F10TEXT(tzpjq1,0);tzpjt2:=F10TEXT(tzpjq2,0);tzpjt3:=F10TEXT(tzpjq3,0);tzpjt4:=F10TEXT(tzpjq4,0);tzpjt5:=F10TEXT(tzpjq5,0);tzpjt6:=F10TEXT(tzpjq6,0);DRAWTEXTEX(C,1,650,850,tzpjt1+'\n'+tzpjt2+'\n'+tzpjt3+'\n'+tzpjt4+'\n'+tzpjt5+'\n'+tzpjt6+'\n'),colorgray;hypjqs:=F10FIND('2.2近期明细',tzpjqs);hypjq0:=F10FIND('3.行业预测评级',hypjqs);hypjq1:=F10FIND('评级日期',hypjqs);hypjq2:=F10FIND('201',hypjq1+40);hypjq3:=F10FIND('201',hypjq2+40);hypjq4:=F10FIND('201',hypjq3+40);hypjq5:=F10FIND('201',hypjq4+40);hypjq6:=F10FIND('201',hypjq5+40);hypjt0:=F10TEXT(hypjq0+16,0);hypjt1:=' '+F10TEXT(hypjq1,0);hypjt2:=F10TEXT(hypjq2,0);hypjt3:=F10TEXT(hypjq3,0);hypjt4:=F10TEXT(hypjq4,0);hypjt5:=F10TEXT(hypjq5,0);hypjt6:=F10TEXT(hypjq6,0);DRAWTEXTEX(C,1,650,650,hypjt0+'\n'+hypjt1+'\n'+hypjt2+'\n'+hypjt3+'\n'+hypjt4+'\n'+hypjt5+'\n'+hypjt6+'\n'),colorgray;//基金持股jjcgqs:=F10FIND('1.基金持股',20000);jjcgq00:=F10FIND('【20',jjcgqs);jjcgq0:=F10FIND('基金简称',jjcgqs+10);jjcgq1:=F10FIND('合计',jjcgq0+70);jjcgq2:=F10FIND('合计',jjcgq1+70);jjcgq3:=F10FIND('合计',jjcgq2+70);jjcgq4:=F10FIND('合计',jjcgq2+70);jjcgt00:=f10text(jjcgq00,50);jjcgt0:=f10text(jjcgq0,50);jjcgt1:=F10TEXT(jjcgq1,50);jjcgt2:=F10TEXT(jjcgq2,50);jjcgt3:=F10TEXT(jjcgq3,50);jjcgt4:=F10TEXT(jjcgq4,50);DRAWTEXTEX(C,1,320,0,jjcgt00+'\n'+jjcgt0+'\n'+jjcgt1+'\n'+jjcgt2+'\n'+jjcgt3+'\n'+jjcgt4+'\n'),colorgray;//最近限售股解禁xsjjqs:=F10FIND('3.最近限售股解禁',100);xsjjq0:=F10FIND('解禁时间',xsjjqs+10);xsjjq1:=F10FIND('20',xsjjq0+70);xsjjq2:=F10FIND('20',xsjjq1+70);xsjjq3:=F10FIND('20',xsjjq2+70);xsjjt0:=f10text(xsjjq0,0);xsjjt1:=F10TEXT(xsjjq1,0);xsjjt2:=F10TEXT(xsjjq2,0);xsjjt3:=F10TEXT(xsjjq3,0);DRAWTEXTEX(C,1,320,160,xsjjt0+'\n'+xsjjt1+'\n'+xsjjt2+'\n'+xsjjt3+'\n'),colorgray;//十大股东a:=F10FIND('【十大流通股东】:',1);a0:=F10FIND('主要指标:',1);QSq:=F10FIND('按照资产负债率排名',5000);QSZ:=F10FIND('按照每股收益排名',5000);GD:=STRTONUM(STRRIGHT(F10TEXT(F10FIND('占流通A股比例:',500),22),8));a1:=F10FIND(' 1│',a);a2:=F10FIND(' 2│',a1);a3:=F10FIND(' 3│',a2);a4:=F10FIND(' 4│',a3);a5:=F10FIND(' 5│',a4);a6:=F10FIND(' 6│',a5);a7:=F10FIND(' 7│',a6);a8:=F10FIND(' 8│',a7);a9:=F10FIND(' 9│',a8);a10:=F10FIND('10│',a9);DRAWTEXTEX(C,1,0,0,''+F10TEXT(a1,0)+'\n'+F10TEXT(a2,0)+'\n'+F10TEXT(a3,0)+'\n'+F10TEXT(a4,0)+'\n'+F10TEXT(a5,0)+'\n'+F10TEXT(a6,0)+'\n'+F10TEXT(a7,0)+'\n'+F10TEXT(a8,0)+'\n'+F10TEXT(a9,0)+'\n'+F10TEXT(a10,0)),colorgray;DRAWTEXTEX(C,1,0,250,'大股东占:'+NUMTOSTR(GD,2)+' %'),Colorgray;//控盘情况c0:=F10FIND('控盘情况:',a0);hs:=F10FIND('总户数',500);IF c0>0 THEN BEGINq1:=F10FIND('201',hs+10);q2:=F10FIND('201',q1+40);q3:=F10FIND('201',q2+40);q4:=F10FIND('201',q3+40);g1:=LTRIM(F10TEXT(q1+14,10));g2:=LTRIM(F10TEXT(q2+14,10));g3:=LTRIM(F10TEXT(q3+14,10));g4:=LTRIM(F10TEXT(q4+14,10));gd1:=STRTONUM(g1);gd2:=STRTONUM(g2);gd3:=STRTONUM(g3);gd4:=STRTONUM(g4);户数差1:=gd1-gd2;户数差2:=gd2-gd3;户数差3:=gd3-gd4;end;DRAWTEXTEX(c,1,650,0,'本期:'+numtostr(gd1,2)+'\n'+'上期:'+numtostr(gd2,2)+'\n'+'前期:'+numtostr(gd3,2)+'\n'+'早期:'+numtostr(gd4,2)+'\n'),colorblack;DRAWTEXTEX(c,1,730,0,'本期减少:'+numtostr(-户数差1/gd2*100,2)+'\n'+'上期减少:'+numtostr(-户数差2/gd3*100,2)+'\n'+'前期减少:'+numtostr(-户数差3/gd4*100,2)+'\n'),colorblue;DRAWTEXTEX(c,1,650,95,'股东流通比:'+numtostr(gd1/finance(7),2));bb:=F10TEXT(c0+196,12);DRAWTEXTEX(c,1,650,120,'报表日期:'+bb+'日');

附:【飞狐牛气冲天副图指标公式】

INPUT:G1(8,8,35);股票:=0;理:IF(CLOSE>MA(CLOSE,5),股票+1,股票),COLORWHITE;想:IF(CLOSE>MA(CLOSE,10),理+1,理),COLOR999999;论:IF(CLOSE>MA(CLOSE,20),想+1,想),COLOR00FFFF;坛:IF(CLOSE>MA(CLOSE,60),论+1,论),COLORFF00FF;估:IF(MA(CLOSE,5)>MA(CLOSE,10),坛+1,坛),COLORFFAA00;界:IF(MA(CLOSE,10)>MA(CLOSE,20),估+1,估),COLOR6AFF;文:IF(MA(CLOSE,20)>MA(CLOSE,60),界+1,界),COLORFF;FILLRGN(CLOSE,0,理),COLORWHITE;估算:理+想+论+坛+估+界+文,LINETHICK,COLORFF00FF;G2:=(REF(估算,1)=G1);牛气:=IF(G2,1,0);冲天:STICKLINE(牛气,0,6.8,5,0),COLORBAFF;DRAWICON(牛气=1,7,8);

更多股票公式相关资讯请关注南方财富网

发布评论

最新评论

  • 暂无评论
推荐知识
相关热点文章